Erreur lors de la MàJ de GestSup

Installation & Configuration du logiciel
Répondre
webcarle
Gsup LEVEL 0
Messages : 4
Enregistré le : mer. 1 févr. 2023 15:33

Bonjour,

J'ai installé GestSup sur un hébergement o2switch :
Ma config : Version 3.2.30


Lorsque je clique sur Mise à jour, j'ai cette erreur :
Erreur : Serveur de mise à jour inaccessible vérifier votre accès Internet et votre Firewall.

Pourriez-vous m'indiquer comment mettre à jour SVP ?
Avatar du membre
Flox
Administrateur du site
Messages : 7901
Enregistré le : jeu. 21 juin 2012 19:00

Bonjour,

pouvez-vous transmettre une impression écran de la page Administration > Système ?

Cdt
GestSup: 3.2.35 | Debian: 11 | Apache: 2.4.57 | MariaDB: 10.11.3 | PHP: 8.2.6
webcarle
Gsup LEVEL 0
Messages : 4
Enregistré le : mer. 1 févr. 2023 15:33

Serveur img OS : Linux expresso.o2switch.net 4.18.0-348.12.2.lve.el7h.x86_64 #1 SMP Mon Jan 24 05:45:10 EST 2022 x86_64 (Votre distribution n'est pas compatible, migrer vers Debian)
img Apache : Non disponible (en HTTP/1.1 sur www.cabestan.support)
img MariaDB : 10.6.12-MariaDB (base : ewgh1336_support 2,4MB)
img PHP : 7.4.33 (/opt/alt/php74/etc/php.ini)
GestSup : 3.2.30 (10 tickets / 0 équipements)
Horloge : 2023-03-30 15:47:24 (Europe/Paris)
Fichiers chargés : 0,49MB (total 2,89MB)
Clé privée :
Client Mobile : Non
Navigateur : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/112.0
IPv4 : xx.xx.xx.xx
Paramètres PHP file_uploads : Activé
memory_limit : 512M
upload_max_filesize : 512M
post_max_size : 512M
max_execution_time : 480s
date.timezone : Europe/Paris
Extensions PHP php_curl : Activée
php_fileinfo : Activée
php_ftp : Activée
php_gd : Activée
php_iconv : Activée
php_imap : Activée
php_intl : Activée
php_json : Activée
php_ldap : Activée
php_mbstring : Activée
php_openssl : Activée
php_pdo_mysql : Activée
php_xml : Activée
php_zip : Activée
Sécurité HTTPS : Activée
Version Apache : Non affichée
Version PHP : Non affichée
Durée de la session : PHP=1440s GestSup=240m
Droits d'écriture : Non verrouillés (cf. documentation).
Répertoire installation : Non présent
SMTP : Sécurisé
IMAP : Sécurisé
Mots de passe : Aucune politique définie (définissez une politique de mot de passe dans Administration > Paramètres > Général > Utilisateur).
Logs : Activés
Restriction IP : Désactivé (pour plus de sécurité, il est possible de restreindre l'accès des clients à certaines adresses IP, cf Administration > Paramètres > Général > Serveur).
Listing des répertoires : Désactivé
Composants Ace : 3.1.1
makeusabrew/bootbox : 5.5.3
twbs/bootstrap : 4.5.3
itsjavi/bootstrap-colorpicker : 3.4.0
steveathon/bootstrap-wysiwyg : 2.0.1
harvesthq/chosen : 1.8.7
FortAwesome/Font-Awesome : 6.2.1
fullcalendar/fullcalendar : 5.11.3
highcharts/highcharts : 10.2.1
jquery/jquery : 3.6.1
jeresig/jquery.hotkeys : 0.2.0
thephpleague/oauth2-client : 2.6.1
thephpleague/oauth2-google : 4.0.0
stevenmaguire/oauth2-microsoft : 2.2.0
greew/oauth2-azure-provider : 1.0.1
moment/moment : 2.29.4
PHPMailer/PHPMailer : 6.6.5
barbushin/php-imap : 5.0.0
inetsys/phpgettext : 1.0.12
ifsnop/mysqldump-php : 2.9
FezVrasta/popper.js : 1.16.0
tempusdominus/bootstrap-4 : 5.1.2
Webklex/php-imap : 4.1.1
WOL : 2.1
Avatar du membre
Flox
Administrateur du site
Messages : 7901
Enregistré le : jeu. 21 juin 2012 19:00

Le serveur de mise à jour est bien disponible, vous devez avoir un soucis réseau.
Vous pouvez réaliser les mises à jour de manière manuelle cf doc.
Fichiers joints
2023-03-30 15_59_05_screenshot_gestsup.png
2023-03-30 15_59_05_screenshot_gestsup.png (5.48 Kio) Vu 94 fois
GestSup: 3.2.35 | Debian: 11 | Apache: 2.4.57 | MariaDB: 10.11.3 | PHP: 8.2.6
webcarle
Gsup LEVEL 0
Messages : 4
Enregistré le : mer. 1 févr. 2023 15:33

J'ai retesté le réseau, et tout semble pourtant normal...

Et dans les logs, j'ai ceci :
2023-03-30 16:07:52 Unable to to contact update server Patrick C... xx.82..xx.xx
Avatar du membre
Flox
Administrateur du site
Messages : 7901
Enregistré le : jeu. 21 juin 2012 19:00

Installer les derniers patch stable de manière manuel, vous aurez plus d'informations de débogage dans la section système.

Cdt
GestSup: 3.2.35 | Debian: 11 | Apache: 2.4.57 | MariaDB: 10.11.3 | PHP: 8.2.6
webcarle
Gsup LEVEL 0
Messages : 4
Enregistré le : mer. 1 févr. 2023 15:33

Après passage des patchs jusqu'en 3.2.33, j'ai effectivement une info légèrement plus détaillé :

Avant j'avais ces messages :

- CHECK GESTSUP UPDATE : GestSup update server is offline

et :
- Unable to to contact update server


Maintenant, j'ai un code d'erreur en plus !

J'ai ceci :
- 2023-03-30 16:59:43 ERROR 4 : Unable to to contact update server
et :
- 2023-03-30 16:56:17 ERROR 18 : CHECK GESTSUP UPDATE, GestSup update server is offline

Il semble donc que les MaJ ne fonctionnent toujours pas...

Bien cordialement,
Avatar du membre
Flox
Administrateur du site
Messages : 7901
Enregistré le : jeu. 21 juin 2012 19:00

Pouvez-vous transmettre une impression écran de la page Administration > Système ?
GestSup: 3.2.35 | Debian: 11 | Apache: 2.4.57 | MariaDB: 10.11.3 | PHP: 8.2.6
Répondre